Thursday, April 2, 2009

Microsoft fixes Data Group Bug in Reports!

Woo Hoo!!   Yippee!!  Hooray!!  I'm jumping for joy!!

I'm extremely excited to let everyone know that Microsoft has fixed the serious Data Group bug in VFP 9 SP2 reports which I blogged about here. The bug is officially described in the following Microsoft KB article, where you'll also find detailed instructions on how to get the fix. 

FIX: The group header of a data grouping is not printed at the top of each page as expected after you intall Microsoft Visual FoxPro 9.0 Service Pack 2 (968409)

I've heard lots of developers say they've held off upgrading to SP2 because of this one bug. So those of you that fall in this category .. it's time to upgrade!! There are no more excuses!! 

Several people in the FoxPro Community, myself included, worked hard at getting this bug fixed and spent a lot of time testing it. Please ... I don't want to hear any bitching from anyone about how long it took to get this. Instead, let's all focus on the positive side which is the fact that Microsoft listened and provided a fix to a serious bug.

P.S.  Read Rick Schummer's blog for more thoughts about this bug fix.  

3 comments:

Jack said...

Cathy, thanks so much for you work on this. It is incredibly helpful when weird things happen to know that they are a fox bug and not have to hours/days trying to figure out what you did wrong. It is amazing that you could actually get Microsoft to do something. I have said this before, but your many contributions to the community are overwhelming. Who has the time?

Pluisje said...

Only one thing to say: a big thank you and - of course - the fox team!

marcio28 said...

Cathy, thank you and the fox team so much. Any other bug left or this was the last?
Marcio